Android Gingerbread and Honeycomb Users Won’t Be Able to Update Apps in 2017

android-2-3-gingerbread

Remember Android Gingerbread? How about Honeycomb? Well, they exist, and they’re each over 5 years old. And as noted by this month’s status numbers, each operating system still has a very small number of users, meaning people, for some reason, just won’t upgrade their phone.Whelp, now’s probably the best time ever to do this as in early 2017, you’re gonna be sorry.

Whelp, now’s probably the best time ever to do this as in early 2017, you’re gonna be sorry.

As per a post on the Android Developers Blog, starting with Google Play Services v10.2 that’ll roll out in early 2017, Google will be dropping support for both Gingerbread and Honeycomb, making Play Services 10.0 – 10.1 the last versions to support the older operating systems. This means that users of the two platforms won’t be able to update apps any longer. Instead, the minimum required Android version will be 4.0.1 Ice Cream Sandwich.

Version 10.0.0 of the Google Play services client libraries, as well as the Firebase client libraries for Android, will be the last version of these libraries that support Android API level 9 (Android 2.3, Gingerbread). The next scheduled release of these libraries, version 10.2.0, will increase the minimum supported API level from 9 to 14 (Android 4.0.1, Ice Cream Sandwich). This change will happen in early 2017.

So why stop supporting Gingerbread and Honeycomb now? Well, Google says it’s all about finally getting rid of the systems. Since manufacturers are practically done with the software, there’s really no point in supporting them into 2017. In addition, by increasing the minimum requirement for apps, better experiences can be offered and more advanced features can be used in developers’ applications.

The Gingerbread platform is almost six years old. Many Android developers have already discontinued support for Gingerbread in their apps. This helps them build better apps that make use of the newer capabilities of the Android platform. For us, the situation is the same. By making this change, we will be able to provide a more robust collection of tools for Android developers with greater speed.

Of course, developers will still be able to develop apps for Gingerbread and Honeycomb, but I can’t really see anyone doing this unless their user base is made up of a bunch of people using Android 2.3.7 and Android 3.2.6.

Currently, 1.3% of all Android users use Gingerbread, so with this move early next year, this number will likely decrease and (God willing) Nougat’s stats will take a jump forwards.

Do you still use Gingerbread or Honeycomb?





There is 1 comment

Add yours

This site uses Akismet to reduce spam. Learn how your comment data is processed.

%d bloggers like this: